Upstream Provider Performance
Incident Report for Taplytics
Resolved
Our upstream provider incident has been resolved and website performance is back to normal.
Posted about 4 years ago. Jul 16, 2015 - 12:06 PDT
Investigating
We are investigating issues with our upstream providers, that may be affecting website performance.
Posted about 4 years ago. Jul 16, 2015 - 11:35 PDT