Taplytics Dashboard Degraded Performance
Incident Report for Taplytics
Resolved
This incident has been resolved.
Posted Jul 19, 2022 - 10:36 PDT
Investigating
We are currently investigating an issue with the loading time of the Taplytics Dashboard.
Posted Jul 19, 2022 - 10:12 PDT
This incident affected: Taplytics.com.